Vetocom API is temporarily down

Incident Report for Vetstoria

Resolved

This incident has been resolved
Posted Sep 10, 2026 - 07:43 UTC

Investigating

We're having some trouble connecting to Vetocom. Don’t worry, we have made the Vetocom team aware.
Posted Sep 10, 2026 - 05:27 UTC
This incident affected: Practice Information Management System Integrations (Vetocom).