Idexx Neo API is temporarily down

Incident Report for Vetstoria

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 15:52 UTC

Investigating

We're having some trouble connecting to Neo. Don’t worry, we are liaising with Idexx Neo team to investigate this further.
Posted Jun 17, 2025 - 05:54 UTC
This incident affected: Practice Information Management System Integrations (Neo (Idexx) - AU, Neo (Idexx) - US).