IVC Merlin is temporarily down for certain clinics

Incident Report for Vetstoria

Resolved

We’re back! Merlin should be up and running. Thanks for bearing with us.
Posted Apr 08, 2025 - 10:46 UTC

Monitoring

We can see the clinics are coming back online, and we are monitoring the results.
Posted Apr 08, 2025 - 08:57 UTC

Investigating

The MWI team is currently working to understand the root cause of the underlying issue.
Posted Apr 08, 2025 - 07:30 UTC

Identified

We're having some trouble connecting to certain Merlin platforms. Don’t worry, we have made the MWI team aware.
Posted Apr 08, 2025 - 04:30 UTC
This incident affected: Practice Information Management System Integrations (Merlin).