ProVetCloud API is temporarily down

Incident Report for Vetstoria

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 14:50 UTC

Investigating

We're having trouble connecting to some of the ProVetCloud clinics in the EU region. Don’t worry, we have made the ProVetCloud team aware.
Posted Apr 15, 2026 - 09:37 UTC
This incident affected: Practice Information Management System Integrations (ProVetCloud).