[Idexx-ezyVet] Overlapping Appointments occuring for certain users in APAC and EU

Incident Report for Vetstoria

Resolved

This incident has been resolved.
Posted Feb 03, 2026 - 06:37 UTC

Monitoring

Idexx-ezyVet has implemented a fix, and we are monitoring the results.
The updates can be tracked here: https://status.idexxsoftware.com/incidents/yd7gn7ln0hkx
Posted Feb 02, 2026 - 10:02 UTC

Identified

Idexx-ezyVet has identified an issue affecting ezyCab availability retrieval, which is impacting some of our APAC and EU customers, and a fix is being worked on.
The updates can be tracked here: https://status.idexxsoftware.com/incidents/yd7gn7ln0hkx
Posted Feb 02, 2026 - 08:29 UTC
This incident affected: Practice Information Management System Integrations (ezyVet (Idexx)).