Certain Robovet clinics are temporarily down
Incident Report for Vetstoria
Resolved
This incident has been resolved.
Posted Jun 22, 2024 - 14:14 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 21, 2024 - 18:06 UTC
Investigating
We're having some trouble connecting to Robovet. Don’t worry, we are actively working to get them back online.
Posted Jun 21, 2024 - 14:12 UTC
This incident affected: Practice Information Management System Integrations (Robovet (Covetrus)).