Ezyvet API is temporarily down

Incident Report for Vetstoria

Resolved

This incident has been resolved.
Posted Nov 15, 2025 - 22:00 UTC

Identified

The Ezyvet team has identified the root cause of the issue and is currently working on a resolution.
Posted Nov 14, 2025 - 14:58 UTC

Monitoring

The Ezyvet practices are coming back online and we are monitoring the results.
Posted Nov 14, 2025 - 14:47 UTC

Investigating

We're having some trouble connecting to Ezyvet. Don’t worry, we have made the Ezyvet Support team aware.
Posted Nov 14, 2025 - 09:59 UTC
This incident affected: Practice Information Management System Integrations (ezyVet (Idexx)).